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Sage Intacct user... is not authorized to retrieve...

Overview

While refreshing a report, one or more of the following messages are displayed:

In the Velixo NX Status side panel...

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/q0rtoyKR0RYrdRkB5y--73a7n58AVTxtyg.png


or...

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/BWFADtBn1miftnceMke1RAIWFjNnFu7Tpw.png

In the cell containing the Velixo function:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/xbXdPX3-Po5FMS2gwobtmV2E9xyXcyNq-Q.png

or...

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/40VN6pOV3z2VYuQz3LX82MF4oG0tXkQ17g.png


Text of Message

Sage Intacct user 'username' is not authorized to retrieve 'name of Sage Intacct object'. Please contact your ERP administrator.

or

Sage Intacct user 'username' does not have permission to query 'name of Sage Intacct object'. Please contact your ERP administrator.

Cause

As the message states, the Sage Intacct user account does not have sufficient access rights to retrieve the data being accessed by the Velixo function(s).

Resolution


Some of Sage Intacct's objects may not be accessible if you have a limited user type (other than Business):

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/TcJmomooK41CRM72xA2oroGs-uCIHrafOA.png

For more information on the minimum necessary permissions, please see Minimal permissions for refreshing a Sage Intacct report


If a user account is already a Business account, a system administrator can investigate further.

Within Sage Intacct, we would navigate to the Users page:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/xVHvIg1Ong08MLzCyAREtwIpBH-ucpCdWg.png


From there, click the View permissions and roles link for the for the user mentioned in the Excel error message:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/LAbBZlvD_7mHmeB_1LJomp8u2Ad-latbhw.png


With the displayed Permissions and roles report, we'll navigate to the Roles tab to view the roles assigned to this user account:


https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/9puQ4rNtEFhoJReYQ9uST6MSSY_xowFaBg.png


From this point, there are two possible root causes and resolutions...

Path 1

If a necessary role containing the access rights is missing for this user, it can be assigned.

This is done by closing this permission report, returning to the user list, and clicking the Edit link next to the user account:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/9Av9v_3fviJIsi1mJHwuVNbsOpsBtMOMmA.png


Then, navigating to the Roles information tab and assign any additional role(s) needed for accessing the data:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/WOTFMYwqYUiH5hHYowOCbg0IWBciNvYPhQ.png


Path 2

The other possibility is that the set of assigned roles for the user are sufficient, but some of them are misconfigured and/or missing the necessary access rights.

In this case, from the Permission and roles report, we would click the View link in the Subscriptions column:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/wtTSrCkx3MgkYs0AGNpvQR5sJ7JE5feUeQ.png


Then, we can review that the relevant applications or modules are enabled for the user:


https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/HQlYrb-dwMIETjNQ-jK-NnyIIUasoq_Z5g.png


We can go into detail for each relevant module by clicking the applicable Permissions link:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/tf3sgIGWxggJdpo6jCiXI-ZNcyPE21mE0w.png


We can then verify that the applicable object is available to List and/or View:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/_Gbwz9Pd89XgpG2fo5FjhScGZc4FXxzQ9g.png


For example, for using the Velixo balance functions (debits/credits, closing balance, etc.), the permission to run the Trial Balance and General Ledger reports is required:


https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/gCGYu5u1I_YBttu2HV2kcf0sUjiEctTFiw.png