Error: InvalidVelixoCredentials

Overview

While entering or updating connection information, an error stating that you are using invalid Velixo credentials appears at the bottom of the Velixo NX Connection Manager:


Velixo NX Connection Manager showing the InvalidVelixoCredentials error at the bottom of the form


Text of Message

{"errorCode":"InvalidVelixoCredentials"}

Cause

For some reason, Excel has lost its ability to connect to the Microsoft Store (where Velixo NX is accessed and authenticated).

Workaround

Logging out of Velixo NX and then reloading the add-in should allow Excel to re-establish its connection to the Microsoft Store.

Logging out of Velixo NX

At the top of the Connection Manager, click the Logout button:

Velixo NX task pane showing the Logout button at the top of the Connection Manager


Reloading Velixo NX

Once logged out of Velixo NX, click the left-pointing arrow at the top of the side panel...

Velixo NX task pane after logout showing the back arrow button at the top of the side panel


... and then select Reload from the menu:

Velixo NX side panel menu showing the Reload option to re-establish the Microsoft Store connection


You should now be able to create/update you connection information.