Signing into Velixo using Single Sign-On results in an authentication error

Instructions in this article require admin privileges.

Overview

Trying to log into Velixo with Single Sign-On via Sage Intacct returns the following or similar error:

Velixo sign-in dialog showing an authentication error when attempting Single Sign-On via Sage Intacct

Error message:

AADSTS75011: Authentication method 'X509, MultiFactor, X509Device' by which the user authenticated with the service doesn't match requested authentication method 'Password, ProtectedTransport'. Contact the Sage Intacct application owner.

Cause

This is a result of the authenticator being used by Azure passwordless authentication instead of Microsoft Entra ID supported by Sage Intacct. It is independent of Velixo settings.

Resolution

To resolve this problem, enable Single Sign-On using Microsoft Entra ID in Sage Intacct settings as follows:

  1. Go to CompanySetupConfigurationCompanySecurity tab and select Edit.

Sage Intacct Company Configuration Security tab showing the Edit button highlighted


  1. In the Single sign-on (SSO) section, check the Enable alternative login methods (Microsoft Entra ID only) checkbox.

Sage Intacct Single sign-on section showing the Enable alternative login methods (Microsoft Entra ID only) checkbox to be enabled


  1. Save your changes.

Sage Intacct Company Security page with the Save button visible to apply the updated SSO configuration


Single sign-on must be enabled in Sage Intacct before you can use the passwordless authentication methods. Refer to the Sage Intacct documentation for details.