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Signing into Velixo using Single Sign-On results in an authentication error

Overview

Trying to log into Velixo with Single Sign-On via Sage Intacct returns the following or similar error:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/IQ90vikuXyj3-EhZL4K8r0YjLzMuukCIqg.png

Cause

This is a result of the authenticator being used by Azure passwordless authentication instead of Microsoft Entra ID supported by Sage Intacct. It is independent of Velixo settings.

Resolution

To resolve this problem, enable Single Sign-On using Microsoft Entra ID in Sage Intacct settings as follows:

  1. Go to CompanySetupConfigurationCompanySecurity tab and select Edit.

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/kpG11h6zS8vKJUqRhCAf1bavFK3Z_yYUtw.png


  1. In the Single sign-on (SSO) section, check the Enable alternative login methods (Microsoft Entra ID only) checkbox.

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/B4rnEdUjxJnJ6vDIpfQtkFVB33yyjhlIuw.png


  1. Save your changes.

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/DxZOMGbiVRI2QlPNeRfJteEicZLZkOEbGA.png


Single sign-on must be enabled in Sage Intacct before you can use the passwordless authentication methods. Refer to the Sage Intacct documentation for details.