Balance functions like always return zero for a dimension, while you are able to filter by that "dimension" using the GLDETAIL object

Symptom

Balance functions (like SI.TURNOVER or SI.CLOSINGBALANCE) retrieve zeroes or empty values for particular dimensions (e.g., customer or vendor) regardless of their value; in contrast, a query based on a related field in the GLDETAIL object (e.g. CUSTENTITY) retrieves the matching transactions.

Excel spreadsheet showing SI.TURNOVER returning zero for a Customer dimension filter while an SI.QUERY on GLDETAIL CUSTENTITY returns matching transaction values
Excel spreadsheet showing matching transactions retrieved using the GLDETAIL CUSTENTITY field for the same customer dimension

Cause

A misconfiguration in the Standard dimension display setting in the Dimensions setup section of the affected subledger's settings page can cause one or more dimensions to be unavailable for tagging at the line level of transactions.

Velixo is behaving as expected with the given configuration.

Example

While the example below uses the Customer dimension and the Accounts Receivable subledger, this scenario can apply to any other dimension and subledger available in your Sage Intacct instance.

For instance, Accounts Receivable may be configured so that the Customer dimension is not enabled:

Sage Intacct Accounts Receivable Configuration page showing the Dimensions setup section with the Customer dimension checkbox unchecked

With this configuration, your invoices may be tracked per Customer in the subledger as receivables...

Sage Intacct Accounts Receivable invoice list showing invoices tracked per customer in the subledger

... but note that the AR invoice line level does not enable the selection of a Customer dimension due to the configuration:

Sage Intacct AR invoice entry showing no Customer dimension field available at the line level

As a result, the journal entry lacks the Customer dimension completely.

Sage Intacct journal entry showing the Customer dimension field is absent from the GL line

The key to understanding the situation described in this article is the fact that the CUSTENTITY field of the GLDETAIL object comes directly from the subledger (the AR invoice header). So, while topically related, it is not directly associated with the Customer dimension.

The Customer dimension value in GLDETAIL is stored in the CUSTOMERID field, which remains empty unless the customer dimension is enabled.

Resolution

The resolution described below includes changes in Sage Intacct configuration. You should discuss all configuration changes with your Sage Intacct administrator, and/or a certified Sage Intacct implementer.

This solution applies to new transactions only.

To enable the selection of all needed dimensions for all new subledger entries, open the Sage Intacct web interface, open the Menu drop-down, choose the appropriate subledger (Accounts Receivable in this example) and go to Setup > Configuration.

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Scroll down to the Dimensions setup section, and make sure that the boxes next to the dimensions you need enabled are checked.

Sage Intacct Accounts Receivable Configuration Dimensions setup section showing dimension checkboxes with the Customer dimension now enabled

Click Save in the top-right corner.

Sage Intacct configuration page showing the Save button in the top-right corner