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Error: InvalidVelixoCredentials

Overview

While entering or updating connection information, an error stating that you are using invalid Velixo credentials appears at the bottom of the Velixo NX Connection Manager:


https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/YLK45Adgk0bI5r8mOcbItOFnP3TdK5JAvg.png


Text of Message

{"errorCode":"InvalidVelixoCredentials"}

Cause

For some reason, Excel has lost its ability to connect to the Microsoft Store (where Velixo NX is accessed and authenticated).

Workaround

Logging out of Velixo NX and then reloading the add-in should allow Excel to re-establish its connection to the Microsoft Store.

Logging out of Velixo NX

At the top of the Connection Manager, click the Logout button:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/HSQA0MByCwRgdHDij6n2Q-K0Ewn0l0JfLg.png


Reloading Velixo NX

Once logged out of Velixo NX, click the left-pointing arrow at the top of the side panel...

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/OrEhpPz7Nrf036uAbxl-bJLcrEC99Q_oRg.png


... and then select Reload from the menu:

https://s3.ca-central-1.amazonaws.com/cdn.velixo.com/helpdesk/1qOYxmA7WJ9Il-eGHWObr0T62i-tDNSJqg.png


You should now be able to create/update you connection information.