Breadcrumbs

The GI function cannot access a Generic Inquiry that is available in Acumatica

Symptom

When refreshing a report that contains a GI formula, Velixo shows an error indicating missing permissions / no access to a specific generic inquiry (GI).

At the same time, logging in to Acumatica as the same user and opening the GI manually works correctly.

Screenshot 2026-03-10 at 13.42.46-20260310-124445.png

Cause

This behavior is caused by a known Acumatica issue that occurs:

  • when inserting/importing a GI from XML, or

  • when copying an existing GI.


Because of this corrupted access-rights state, Acumatica itself can still display the GI when opened directly. At the same time, the OData endpoint for the same GI is broken, causing Velixo’s GI function (which uses OData) to fail with a permission error.

To confirm this cause, open the faulty GI in Acumatica and navigate to Tools Access Rights. If you’re presented with an error stating “Sequence contains no elements”, consider the cause confirmed.

image-20260310-132150.png

Workaround

Ensure your user has the rights to access the Generic Inquiry in question. Then, follow the steps below.

  1. Open the GI in Acumatica.

  2. Go to CustomizationEdit Generic Inquiry.

    e0fd4920-21ad-46c8-a334-4ee7262b9615-20260310-141403.png



  3. Click UNPUBLISH, confirm by clicking OK, and uncheck the Expose via OData checkbox.

    image-20260310-132810.png


  4. Click PUBLISH TO THE UI, confirm by clicking PUBLISH, check the Expose via OData checkbox, and click the Save icon.

    image-20260310-133425.png