Add-in stops working after a Velixo update

Overview

Upon opening Microsoft Excel, Velixo NX prompts for an update, but clicking Update now results in an error, preventing the add-in from being used. This issue affects all users and occurs consistently during an update.

Excel error dialog with the heading We couldn't upgrade this app and the body text You failed to upgrade this app, please contact your IT admin for help. The dialog appears over the Velixo NX Update Add-in panel.

Cause

Due to a known Microsoft Excel issue, the update process can leave the add-in in a broken state. This is typically caused by a conflict between the newly installed version of the add-in and the previously cached version in Excel, preventing the add-in from loading correctly.

Resolution

Step 1: Restart Excel and install Office updates

On Windows (On Mac, proceed to Step 2), before re-installing the add-in, try the following — this is sufficient to resolve the issue in many cases:

  1. Completely close all Excel windows and reopen Excel.

  2. Install all available Microsoft Office updates:

    1. In Excel, go to File > Account.

    2. Under Product Information, click Update Options > Update Now.

      Excel Account screen with the Update Options menu open, highlighting Update Now
    3. Once updates are installed, restart Excel and check whether the add-in is working.

Step 2: Reinstall the add-in

If the issue persists after Step 1, re-install the add-in in Excel:

  1. In Excel, go to File > Options > Add-ins.

  2. Locate the Velixo add-in and remove it.

    1. If the add-in is deployed centrally, and you cannot remove it, contact your company administrator.

    2. Otherwise, please refer to this page: Uninstalling Velixo NX.

  3. Re-add the Velixo add-in.

  4. If the issue persists, restart your computer and verify that the add-in is working.