Error: An item with the same key has already been added
Created by Harry Lewis, Modified on Tue, 16 Jul at 9:35 AM by Gabriel Michaud
Applies to:
- Velixo Classic
- Velixo NX
- Acumatica, CEGID, Haufe x360, JAMIS Prime, MYOB Acumatica
TABLE OF CONTENTS
Overview
When refreshing a workbook containing Velixo functions, the following message is displayed for some functions:
Text of Message
Error! An item with the same key has already been added.
Cause
For performance reasons, Velixo caches certain data returned by the functions in your workbook (so that you do not have to retrieve identical data from your ERP over and over again).
Sometimes, the cached data may be out-of-date and cause an issue when attempting to access it. In this case, it is necessary to re-retrieve the data from the ERP
Resolution
Perform a Full Refresh of your Velixo functions:
This will not only retrieve the latest data from the ERP, but it will also update the cached data.
Was this article helpful?
That’s Great!
Thank you for your feedback
Sorry! We couldn't be helpful
Thank you for your feedback
Feedback sent
We appreciate your effort and will try to fix the article