MYOB Error: You are not allowed to log in as you don't have any API user licenses
Created by Damien Zwillinger, Modified on Wed, 9 Oct at 3:09 PM by Harry Lewis
Applies to:
- Velixo NX
- Velixo Classic
- MYOB Acumatica
Symptom
When using using Velixo to access MYOB Acumatica, you can see the following message:
Text from Message:
System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> PX.Data.PXException: You are not allowed to log in as you don't have any API user licenses
at MYOB.AdvancedLive.Core.Services.LicenseServiceImpl.ValidateUser()
at PX.Data.PXLogin.PX.Data.IPXLogin.LoginUser(String& userName, String password)
at PX.Api.Services.LoginService.Login(String login, String password, String company, String branch, String locale, String prefix)
at PX.Api.ContractBased.ILoginServiceExtensions.LoginForSoapApi(ILoginService loginService, IMultiFactorService multiFactorService, String login, String password, String company, String branch, String locale)
at PX.Api.Soap.Screen.ScreenGate.Login(String name, String password)
Cause
MYOB Acumatica has special user licensing requirements for using certain features, such as:
Creating or updating inquiries
Using Writeback
If the user profile being used to access MYOB does not have an API license, the above message is displayed.
Resolution
Either the user profile would need to have an API licensed assigned to it...
... or the action being attempted would need to be done by someone whose user profile already has an MYOB API license.
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