Error: Can't Contact The Server

Created by Damien Zwillinger, Modified on Tue, 05 Sep 2023 at 10:33 PM by Damien Zwillinger

Applies to:

  • Velixo NX
  • Excel 365 Online
  • Every ERP


Overview

When attempting to refresh your report using Velixo NX in Excel Online, the following message appears:

not_able_to_contact_server.png


Text of Message:

Can't Contact the Server

We're not able to contact the server. It might not be responding, or your internet connection ma have been interrupted. Please try again.


Cause:

The report contains more custom functions (including Velixo NX functions) than Excel Online is able to handle.

There is a (currently) undocumented limit in Excel Online of 50,000 custom functions. If that limit is exceeded by a workbook, Excel Online will display the message shown and propose that the page be reloaded.


Resolution

At the time of this writing, the only known resolution to this issue is to break up large reports into separate, smaller reports so that the total number of custom functions in any one report is below the 50,000 limit that can be handled by Excel Online.


Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select atleast one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article