Overview

When starting Excel with Velixo Reports installed, the following message is displayed:

Text of Message

VelixoReportsPro64.xll Add-in Loader

A problem occurred while the add-in was creating an isolated application domain and loading required assemblies.

The ExcelDna.ManageHost.AddinInitialize.Initialize call failed.

Check that there is no obsolete version of ExcelDna.Inrtegration.dll present. This file can be safely deleted.

This add-in is built with Excel-DNA and is being loaded from the following location:

C:\users\{username}\AppData\Roaming\Velixo\Velixo Reports Pro for Excel and Acumatica\VelixoReportsPro64.xll.

Cause

An update to Microsoft Windows Defender published on November 9th, 2021 by Microsoft has resulted in a "false positive" for a component used in the release of Velixo Reports version 4.0.411.

Microsoft’s Windows Defender can help protect your PC from nasty bugs and viruses you can pick up on the internet. Sometimes though, it can be a tad too overzealous and identify a file or file type as dangerous, calling it to your attention even though it is perfectly harmless.

We have verified the affected file using VirusTotal to confirm that the file is safe. VirusTotal inspects items with over 60 antivirus scanners, in addition to a myriad of tools to validate the files submitted. The inspection report shows that no other security vendor consider this file as problematic.

We have submitted the issue to the Microsoft Defender ATP Team immediately after discovering the issue.

Resolution

Velixo Reports version 6.0.679 (or higher) resolves this issue and can be downloaded from the Velixo Insider Channel.

Workaround

If, for some reason, your organization is unable to install the latest release of Velixo Reports 6.0.679, you would need to configure Windows Defender to ignore this false positive.

First, open the Start Menu and search for Windows Security:

Within Windows Security go to Virus & threat protection:


The recent issue should show directly under Current threats as "Trojan:MSIL/AgentTesla.R!MTB":

Note: if you don't see the issue with this name under the "Current threats", do the following:

  • Keep Windows Security open on the Virus & threat protection tab.

  • Start Microsoft Excel again up to the point where you saw the add-in error.

  • This should ensure that the issue appears under the "Current threats", and you'll be able to act quickly upon it.

Click the arrow next to Trojan:MSIL/AgentTesla.R!MTB


Select Allow on device:

and then click on Start actions.

If you are using Microsoft 365 Defender, your system administrator may have to follow a different procedure. For more information, please visit the following link: Address false positives/negatives in Microsoft Defender for Endpoint


You should now be able to start Excel normally and see the Acumatica ribbon in the toolbar:

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