Symptom
When defining a connection to an Acumatica tenant, the user is presented with a message about one or more inquiries not being set up and asking if the user would like to create them:
After clicking Yes, the user is presented in an error message:
Text from the Error Message:
An error occured during configuration of inquiry VelixoReportPro-xxxxxxxx. Please ensure that you have the necessary access rights to create a Generic Inquiry.
System.Web.Services.Protocols.SoapException: Server was unable to process request. --->
System.NullReferenceException: Object reference not set to an instance of an object.
Cause
This error is being returned by Acumatica and indicates that the user does not have sufficient permissions to create the Generic Inquiry
Resolution
An Acumatica Admin (or other user with sufficient access rights) will need to either:
use the Velixo Reports add-in to create the new Generic Inquiries or
install or update & publish the latest Acumatica Customization Project